[前][次][番号順一覧][スレッド一覧]

rabbit-shocker:1271

From: "-E:), niku" <niku@n...>
Date: Tue, 8 Sep 2015 11:07:11 +0900
Subject: [shocker-ja:1271] Re: 2.1.7 Macでのインストールについて

にくです

たしかに自分のところでも同じ現象にあたりますね.
(すみません,起動するところまでは見ていませんでした)

今のところ私の手元でも起動させられませんでした.
何かうまくいく方法が見つかったらまたお知らせします.


2015-09-07 12:48 GMT+09:00 Junichi Oya <tropicaljazz@g...>:
> にくさま
>
> ありがとうございます。インストール出来ました。
> ただ、以下のメッセージが出て、動作しません。
> ネット上をみているのですが、前進せず、こちらに投稿します。
>
> よろしくお願い致します。
>
> % rabbit
>
> dyld: lazy symbol binding failed: Symbol not found:
> _Init_cairo_quartz_surface
>
>   Referenced from:
> /Users/junichi/.rbenv/versions/2.0.0-p645/gemsets/rabbit/gems/cairo-1.14.2/lib/cairo.bundle
>
>   Expected in: flat namespace
>
>
> dyld: Symbol not found: _Init_cairo_quartz_surface
>
>   Referenced from:
> /Users/junichi/.rbenv/versions/2.0.0-p645/gemsets/rabbit/gems/cairo-1.14.2/lib/cairo.bundle
>
>   Expected in: flat namespace
>
>
> [1]    28620 trace trap  rabbit
>
>
>
>
>
> 2015年9月7日 11:17 -E:), niku <niku@n...>:
>
>> にくです.
>>
>> homebrew をお使いでしょうか?
>> 私は homebrew を使っていて,
>> OS X で rabbit を含む Gemfile を bundle update したときに同じエラーが出ました.
>> gio2 2.2.5 と gobject-introspection 2.2.5 をアップデートできなかったようです.
>>
>> libffi doesn't exist を Google で検索して,一番上に出てきた
>> 『Unable to install gobject-introspection 2.2.2 on OSX 10.9.5』
>> https://github.com/ruby-gnome2/ruby-gnome2/issues/259
>> を参考に
>> PKG_CONFIG_PATH=/usr/local/opt/libffi/lib/pkgconfig bundle update
>> とするとエラーなくインストールできました.
>>
>> たぶん同様に
>> PKG_CONFIG_PATH=/usr/local/opt/libffi/lib/pkgconfig gem install rabbit
>> とするとインストールできるんじゃないかなと思います.
>>
>>
>> 2015-09-06 17:38 GMT+09:00 Kouhei Sutou <kou@c...>:
>> > 須藤です。
>> >
>> > In <CAB8G0wv45beOtzDT=Nhyy0_3oFcMeYMxAMo87H2NSDK3o8ZcRA@m...>
>> >   "[shocker-ja:1267] 2.1.7 Macでのインストールについて" on Sun, 6 Sep 2015 16:46:25
>> > +0900,
>> >   Junichi Oya <tropicaljazz@g...> wrote:
>> >
>> >> いつもRabbitを使わさせて頂いております。
>> >> 2.1.7リリースおめでとうございます。
>> >
>> > ありがとうございます!
>> >
>> >> インストールしようとしたところ、以下のメッセージがでてインストールでき
>> >> ませんでした。
>> >> こちらの環境面の問題かもしれませんが、ご指導いただければ嬉しく思います。
>> >>
>> >> % gem install rabbit
>> > ...
>> >>
>> >> /Users/junichi/.rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/gems/pkg-config-1.1.6/lib/pkg-config.rb:265:in
>> >> `parse_pc': .pc for libffi doesn't exist. (RuntimeError)
>> >
>> > ここでlibffi.pcというファイルを見つけられていないことが原因
>> > だと思います。
>> >
>> > OS Xユーザーの人でgem install rabbitに失敗する人っていますか?
>> > だれか試してみてもらえないでしょうか?
>> >
>> > --
>> > ML: shocker-ja@m...
>> > Info:
>
>
>
>
> --
> <<<<<<<<<<<<<<<<<
> Junichi Oya
> tropicaljazz@g...
>>>>>>>>>>>>>>>>>>

[前][次][番号順一覧][スレッド一覧]

   @  1267 2015-09-07 01:46 [tropicaljazz@g...   ] 2.1.7 Macでのインストールについて                   
      1268 2015-09-07 02:38 ┗[kou@c...            ]                                        
      1269 2015-09-07 20:17  ┗[niku@n...           ]                                       
   @  1270 2015-09-07 21:48   ┗[tropicaljazz@g...   ]                                      
->    1271 2015-09-08 20:07    ┗[niku@n...           ]                                     
      1272 2015-09-08 20:22     ┗[niku@n...           ]                                    
   @  1273 2015-09-08 21:03      ┣[tropicaljazz@g...   ]                                   
   @  1274 2015-09-09 07:22      ┃┗[tropicaljazz@g...   ]                                  
   @  1275 2015-09-09 19:17      ┃ ┗[niku@n...           ]                                 
   @  1276 2015-09-10 05:03      ┃  ┗[tropicaljazz@g...   ]                                
      1278 2015-09-10 06:10      ┃   ┗[kou@c...            ]                               
   @  1279 2015-09-10 07:20      ┃    ┗[tropicaljazz@g...   ]                              
   @  1280 2015-09-10 07:30      ┃     ┗[tropicaljazz@g...   ]                             
      1281 2015-09-10 08:15      ┃      ┗[kou@c...            ]                            
      1282 2015-09-10 18:36      ┃       ┗[niku@n...           ]                           
      1277 2015-09-10 06:04      ┗[kou@c...            ]